Flatcast Plugin Download
Sorry, but the show cannot be entered. You need a special FLATCAST plugin to join the show, which is not yet installed on the PC.

The plugin required is Viewer F5.2.2Please load the Plugin using the download link below. Afterwards, run through the installation routine. For some browsers it is necessary to restart them after installation.

Help can be found in the Flatcast Forum.

Flatcast Viewer F5.2.2
Download

Flatcast
Advertisement